Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Client FPS insanely low and lagging


    Cj1010
     Share

    Recommended Posts

    I'm on a MacBook Pro and the only possible way to use this client is if I put on cpu save mode with 4 FPS. if not its ridiculously laggy. I've tried everything. Runelite and other oars platforms works fine its just Dreambot 

    these are my settings


      "cpuSaver": true,
      "clientRendering": false,
      "useRandomWorld": true,
      "useCustomWorld": false,
      "fps": 4,
      "customWorld": 0,
      "disableSecurityManager": false,
      "developerMode": false,
      "freshStart": true,
      "sdnIntegration": true,
      "covertMode": false,
      "mouseSpeed": 87,
      "autoAddAccounts": true,
      "lastScriptCategories": 7,
      "breaks": [],
      "lastCanvasSize": "765:503",
      "forcedFPS": -1,
      "roofSolverActive": false,
      "dismissSolversActive": true

     

     

    if I change the cpu mode off it basically freezes for a few seconds shows a new frame then freezes again and keeps going on and on and on like this. if I leave it at 4ps its slow but its somewhat usable

    Link to comment
    Share on other sites

    • 1 month later...
    On 10/11/2020 at 1:27 PM, Pandemic said:

    This is a known issue with certain Mac models, it'll be a while before I'm able to debug it properly as it works fine on my Mac :(

    This just started happening on my computer unfortunately (macOS Catalina 10.15.5) - any shot this will be fixed in the next version, or I can help with debugging?

    Link to comment
    Share on other sites

    • 3 weeks later...
    40 minutes ago, Im A Baller said:

    Any shot this will be fixed soon? Need this to test scripts and my delivery for a new computer is stalling 😕 

    Unlikely at this time, still haven't ran into this problem myself :( You should be able to run it on a VM running linux/windows however and the issue isn't there.

    Link to comment
    Share on other sites

    • 3 weeks later...

    I have the same issue :( dreambot used to run smoothly on my macOS

    I think its macos Catalina, cannot update to bigSur yet because im working on a project that has trouble with it. In a few weeks I can update to bigSur and see if it changes anything. Any update on a fix maybe?

     

    Link to comment
    Share on other sites

    • 1 month later...
    • 2 weeks later...

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.