Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Quickstart sign in broken?


    yeeter01
     Share

    Recommended Posts

    This could just me improperly using this or misunderstanding what it is used for but was attempting to automate the creation, startup, and setup of bot rigs with docker.  Was playing around with quickstart and was under the impression after initial launch I could use the -username and -password fields to sign into my DreamBot account.  The command I am using listed below.

    java -jar %homepath%\DreamBot/BotData/client.jar -username yeeter01 -password MYPASSWORD

    When trying to do this I end up just getting the client to launch and it prompting me to sign in.  Which defeats the purpose of me trying to automate this initial setup between all my docker instances. First thing I did was check my username and password.  Copy pasted them from the command into the site and confirmed they were correct.  Logged into the client manually and tried the command again starting up a single bot on a dummy script.  Worked just fine.  Signed back out ran the same command and again with it got stuck prompting me for the login panel.  Some warnings were printed to console but I personally was not sure what to deduce from these log messages or if it just wasn't intended to be used in this manner.

    [INFO] Connecting to server...
    [INFO] Connected to server!
    [WARN] YOU CAN'T HAVE MORE THAN 0 TABS!
    log4j:WARN No such property [conversionPattern] in org.apache.log4j.PatternLayout.
    log4j:WARN No such property [conversionPattern] in org.apache.log4j.PatternLayout.
    log4j:WARN No such property [maxFileSize] in org.apache.log4j.RollingFileAppender.
    log4j:WARN No such property [file] in org.apache.log4j.RollingFileAppender.
    log4j:WARN File option not set for appender [LocalFile].
    log4j:WARN Are you using FileAppender instead of ConsoleAppender?
    [WARN] You're part of: NOT LOGGED IN

    If I am just misusing this and its not possible any help automating the sign in process would be great =D thanks in advance. 

     

    ***side note*** Tried this on my desktop and laptop as well and ran into the same issue just to make sure it wasn't something dumb with docker. 

    Link to comment
    Share on other sites

    8 minutes ago, Nuclear Nezz said:

    Ahh
    I think I see the issue. I'll see what I can do, I'll get it resolved for the next release.

    Thanks Nezz!  Will post a tutorial on automating client install and setup with docker once fixed. <3

    Link to comment
    Share on other sites

    17 hours ago, yeeter01 said:

    Thanks Nezz!  Will post a tutorial on automating client install and setup with docker once fixed. <3

    Alright, I'm pretty sure it's solved for next release.
    At the very least, it didn't break anything hah

    When I have some other stuff to add to the release, I'll update

    Link to comment
    Share on other sites

    6 minutes ago, Nuclear Nezz said:

    Alright, I'm pretty sure it's solved for next release.
    At the very least, it didn't break anything hah

    When I have some other stuff to add to the release, I'll update

    Thanks Nezz!

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.