Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Client Loads Extremely Small on windows 10


    Recommended Posts

    Hey Guys, kind of new to dream bot. 
    I have no problem getting it loaded on my mac book, but I am not often on that computer. 
    I have tried both version of Java, (32 bit & 64 bit)

    The screen comes out super small, and I have not been able to figure out a setting to change that. 
    Any help would be awesome. 





    Link to comment
    Share on other sites

    • 6 months later...

    I found a post from Reddit that may help.


    Link to original post: https://www.reddit.com/r/Surface/comments/3rgn4h/sp4_scaling_problems/



    [–]Silversee 8 points

    2 years ago *


    This happens because the Java runtime stupidly tells Windows that it is high-DPI aware, which prevents Windows from applying automatic scaling to Java applications. (Believe it or not, there was actually a bug filed back in 2006 to add this behavior to Java when Vista was launched... it's never been reversed, apparently.).

    However, I can tell you how to override this. First, a little background:

    A flag telling Windows whether or not an application is high-DPI aware is set in an XML "manifest" when the program is compiled and packaged. (A lot of applications abuse this mechanism.) Normally, this manifest is embedded within the application, but Windows also has the ability to use external manifest files if they exist. However, you have to modify the Registry to tell Windows to do so. We are going to do this for Java.

    To fix this issue, carefully follow the directions for modifying the Windows registry detailed in this blog post by Dan Antonielli: http://www.danantonielli.com/adobe-app-scaling-on-high-dpi-displays-fix/

    Then, download his 'photoshop.exe.manifest' file to your desktop. (Note that you currently can't use Edge to do this, you'll have to open the page in IE, then right-click on the link and choose 'Save target as...')

    Rename this file to 'javaw.exe.manifest'. (It will help if you temporarily turn on display of file extensions in Windows File Explorer.)

    Make sure you are using the very latest 64-bit Java runtime (8u65) from here: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html. (I'd uninstall any 32-bit version first, if you have one installed.)

    Find your Java installation folder (on my machine it is C:\Program Files\Java\jre1.8.0_65), then copy the manifest file you downloaded and renamed into the 'bin' folder there. The idea is that the manifest file needs to be in the same directory as the 'javaw.exe' executable. You will need admin privileges to do this, so be prepared for a UAC prompt.

    Finally, reboot your computer to make sure Windows picks up the registry change.

    Now, you should be able to run the Mars application and have it scaled properly for your Surface's high resolution display!

    Edit: remember to uncheck the option to disable high DPI scaling in the app's Compatibility Settings if you previously had set that.

    Good luck and let us know when you get this working.



    Link to comment
    Share on other sites


    This topic is now archived and is closed to further replies.

    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.