Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Error java.lang.NullPointerException when I try to start any script


    Khannibal
     Share

    Recommended Posts

    Hi,

     

    I've got this error (Not played in years) tried searching for key words to it but I can't find any explanation for this error or how to get past it. It's when I press 'Start' after a paint for a script pops up. It's happened on both Wintertodt scripts;

     

     

    2.PNG

    Link to comment
    Share on other sites

    EDIT: Things I have tried since getting this issue;

     

    • Clearing my Jagex Cache
    • Removing all older versions of the client, other clients, Runelite, OSRS official client
    • Searching "JagexCache" and deleting every folder with any information
    • Manually uninstalling all programs with Control Panel
    • Re-installing official OSRS client and logging in once to redownload cache
    • Downloading Dreambot again, and checking every possible setting to make sure they aren't stopping me getting on
    • Finally, deleting the OS client and Dreambot from C drive and reinstalling it on E: 

    As it stands nothing has worked and i'm out of ideas on what to do. It let's me log in, it shows me the paint but as soon as I click 'Start script' I get this error and it tries repeatedly to start and duplicates the error.

    Any advice at all appreciated

    Link to comment
    Share on other sites

    I'm able to get NEX Wintertodt to start but it gets stuck looking for items I have, when I finally get it to a point where it's able to start I get the same error.

     

    As it stands i've only tried the two wintertodt scripts, one is outdated the  other one isn't working - i've tried Lily's Cooker Lite just to check and it says "The script's GUI is causing performance issue" and won't open a bank. I've tried GCutter just now to see if that can do a basic script, I get the same GUI error and it's saying there's no axe in my inventory and won't open the bank.

    I'm not sure if literally all the scripts i've tried are just completely outdated, or something's going wrong with my settings or system but the only one i'm really interested in getting to work is NMZ v3.04 by Hashtag, every script i've tried so far doesn't seem to be able to open a bank or acknowledge items in my inventory. Half give me a GUI error the other half the error in the first post.

     

    EDIT: Okay so I downloaded Walkaholic to see if a script that didn't need items could work and it does no issue. So either these scripts are dead, something in my settings is stopping them starting and stopping some banking or there's something going on I have no idea about. Any help is massively appreciated. I did message @Hashtag and he believed it seemed to be a client, not a script issue.

    Edited by Khannibal
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.