Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Fightaholic - The scrappy AIO fightin' script - Now with Quick Prayer support!


    holic
     Share

    Recommended Posts

    Fightaholic has been updated and is now live on the SDN!

    It's currently at v1.2 and is available in the client!

    Changes:
    • Added Stronghold of Security - beta support
    • Added custom NPC textfield - case sensitive, separate by commas
    • Added gamer fatigue - actions become slightly slower the longer the script runs, resets on rests
    • Improved ActionCheck
    • Improved Aggro mode and considered released
    • Improved Bank handling
    • Improved Dungeon handling
    • Improved initialization process, doesn't hang
    • Improved Targeted handling
    • Improved Prayer Potion handling
    • Improved Walk handling
    • Improved Human-like methods
    • Improved GUI
    • Prettier paint
    Thanks!
    Link to comment
    Share on other sites

    In security stronghold goes all the way up to the top floor then crashes, instead of banking at edge. "The script threw an error, please contact the script writer". Doesn't bank for food and just stands around - Status: Shit, we need food. 

    Keeps opening and closing bank after taking food/str pots in inventory. - 

    Edited by KZone420
    Link to comment
    Share on other sites

    On 10/2/2021 at 7:12 AM, romanaka3 said:

    http://prntscr.com/1ui11ki <<< this is spot 
    also runs to this place when finished targed

    Thanks for sharing, would you mind posting your log as well?

    1 hour ago, KZone420 said:

    In security stronghold goes all the way up to the top floor then crashes, instead of banking at edge. "The script threw an error, please contact the script writer". Doesn't bank for food and just stands around - Status: Shit, we need food. 

    Keeps opening and closing bank after taking food/str pots in inventory. - 

    Please post your config. Also SoS is considered in beta so expect some issues for now.

    Link to comment
    Share on other sites

    9 hours ago, holic said:

    Thanks for sharing, would you mind posting your log as well?

    Ok i will try 
    i did open once and its seems like walked to far away and could find any selected enemy to kill

    Link to comment
    Share on other sites

    great script! my only problem i've came across is using potions, ive ticked use attack and strength potion and entered the amount of potions. "super strength" and amount 1. always say "missing strength potion" then says going to bank for more potions. so far running without the use of potions, also tried using normal strength potions and still no luck. anyhelp fixing this would make this script 10/10!!!

    Link to comment
    Share on other sites

    1 hour ago, Spartanwars said:

    great script! my only problem i've came across is using potions, ive ticked use attack and strength potion and entered the amount of potions. "super strength" and amount 1. always say "missing strength potion" then says going to bank for more potions. so far running without the use of potions, also tried using normal strength potions and still no luck. anyhelp fixing this would make this script 10/10!!!

    It's case-sensitive so make sure you've entered it as "Super strength" or "Strength potion".

    4 hours ago, romanaka3 said:

    Ok i will try 
    i did open once and its seems like walked to far away and could find any selected enemy to kill

    While using aggro mode or just in general?

    Link to comment
    Share on other sites

    The bot was running amazingly smooth for me and now it just doesn't fight anymore. Gets stuck at different statuses: Checking potions..., checking runes, forcing a fight... etc.

     

    I haven't been able to get it to do anything anymore, no matter my configurations.

     

    Please help, this was such an awesome bot!

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.