Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • DreamBot v3.1.1


    Pandemic
     Share

    Recommended Posts

    When I'm using the DBLauncher 3.1.1 it is able to start up fine and run however the game client is about 3-4 seconds behind my actual actions. The Dreambot interface doesn't have any input lag, it is just the game itself. 

    I tested the DB2 Launcher (from https://dreambot.org/DB2Launcher.jar) and it worked fine. I also tested the official OSRS launcher and it also worked fine. In both cases there wasn't any input lag. I tested DB3 using the max MB (1024) as well as a range of other lower options and still received the same input lag. I also tested it using the various settings options in the Dreambot client and didn't see any change. 

    I've attempted using the suggested JDK (adopt open JDK 11) as well as a few others (Oracle official JDK 8, Azul JDK 8, 11 and 15) and received the same behavior with all of them. 

    I'm running:

    • MacOS Catalina 10.15.7 
    • 2.6 GHz 6-Core Intel Core i7
    • 16 GB 2400 MHz DDR4
    • Radeon Pro 560X 4 GB
    • 1Gb Ethernet (cable, not wifi)

    So it should be able to handle this without any problem. I'm also not using any VPN, proxy, etc. that would limit my network. 

    I used JMX on the JAR process (with VisualVM)  but didn't see anything overly concerning. The CPU usage is a little high at times (35%-55%). 

    Any thoughts on how to fix the input lag to the actual game? I'd like to start writing scripts against the newest API however I can't test them currently as I can't really run Dreambot in a way that is feasible. 

    Let me know if you need any more information from my end. Thanks!

    Link to comment
    Share on other sites

    5 hours ago, Thirsty Goat said:

    I guess I can't edit my original reply. I meant to specify that is isn't just input lag. The game itself is also freezing for the 3-4 seconds, then jumping once it syncs back up. 

    Do you have antivirus or firewall?

    run java -version in console and show us the exact version here in chat e.g. for me my mac:

    java version "1.8.0_251"
    Java(TM) SE Runtime Environment (build 1.8.0_251-b08)
    Java HotSpot(TM) 64-Bit Server VM (build 25.251-b08, mixed mode)

    Edited by LordJashin32
    Link to comment
    Share on other sites

    For Dreambot, I'm using the suggested AdoptOpenJDK 11. I use jenv (https://www.jenv.be/) to manage various versions of Java at once on my mac so that is how I was switching the java versions I was testing. 

     

    Here is the full output of java-version 

    openjdk version "11.0.8" 2020-07-14
    OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.8+10)
    Eclipse OpenJ9 VM AdoptOpenJDK (build openj9-0.21.0, JRE 11 Mac OS X amd64-64-Bit Compressed References 20200715_677 (JIT enabled, AOT enabled)
    OpenJ9   - 34cf4c075
    OMR      - 113e54219
    JCL      - 95bb504fbb based on jdk-11.0.8+10)

     

    I do have a system firewall on however I allow incoming connections for java applications. I didn't see any issue with running the latest version of Dreambot 2 or the actual OSRS client. Was there some update in Dreambot 3 that would require some change on my end?

    I just tried turning the firewall off and didn't see any difference. 

    Link to comment
    Share on other sites

    yeah no idae what could be causing your problem here. Have u tried any other games besides osrs? is there a possible gpu issue?

    Just trying to help. If you can. Get VIP and run the client from console and give us that output as well. Cheers. Hope it figures out.

    Link to comment
    Share on other sites

    Yeah, I've got plenty of other games that run fine. From the logs I see

     

    2020-10-10 11:14:09 [INFO] Connecting to server...
    2020-10-10 11:14:09 [INFO] You have successfully been logged in as Thirsty Goat!
    2020-10-10 11:14:09 [INFO] Your current rank(s):
    
    [MEMBERS]
    2020-10-10 11:14:10 [INFO] Successfully loaded 216 worlds!
    2020-10-10 11:14:10 [INFO] Starting new instance...
    2020-10-10 11:14:10 [INFO] Attempting to connect to OSRS...
    2020-10-10 11:14:10 [INFO] Connection successful!
    2020-10-10 11:14:10 [INFO] Attempting to start new applet...
    2020-10-10 11:14:10 [INFO] Opened gamepack connection!
    2020-10-10 11:14:11 [INFO] Preparing gamepack for start...
    2020-10-10 11:14:12 [INFO] Successfully started new applet!
    2020-10-10 11:14:12 [INFO] Loaded 381 field definitions!
    2020-10-10 11:14:12 [INFO] Successfully started new instance!
    2020-10-10 11:14:13 [INFO] DreamBot has started successfully!
    2020-10-10 11:17:51 [INFO] Saving client settings...
    2020-10-10 11:17:51 [INFO] Client settings saved successfully!
    2020-10-10 11:17:51 [INFO] Successfully saved client settings!

     

    When starting via terminal:

    java -jar DBLauncher.jar 
    Client is up to date and ready to launch!
    On a mac system, disabling hardware acceleration...

     

    Not sure if the disabling of hardware acceleration has anything to do with it. Is there a way to launch the JAR with increased logging? (like a log4j JVM arg or similar) 

    Link to comment
    Share on other sites

    I switched to my Windows 10 partition via MacOS Boot Camp and Dreambot seems to run fine there. I can use this as a workaround for now but I'd prefer to use my MacOS for development. 

    Link to comment
    Share on other sites

    • Pandemic unpinned this topic
    • 4 weeks later...

    I’m also having this issue with macOS. I got VIP today and everything but still super buggy. Java installed exactly as the guide pointed out, but there is a lag in the client loading frames. I’d really appreciate some advice because this adds a whole lot more risk for a ban with the crazy mouse movements needed to load the frames. 

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.