Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Game doesn't launch depending on machine


    Aeglen
     Share

    Recommended Posts

    Backstory: In Summer 2016 I wanted to look at botting and tried using DreamBot (since it looked the most promising of the softwares), only to find that the game wouldn't launch. Instead I used the far inferior other-bot-beginning-with-p whose API honestly made me hate java... anyhow now I am having another go, with a new computer, something interesting seems to be happening:

    This computer: Win 8.1, Java 8 32-bit. Dreambot hardly ever has any issues launching the game. There are never any issues launching the jar or client.

    Other computer#1: Win 7, Java 8 64-bit. Dreambot only manages to launch the game ~2% of the time. There are never any issues launching the jar or client.

    Other computer#2: Win 7, Java 8 32-bit. Dreambot hardly ever has any issues launching the game. There are never any issues launching the jar or client.

    Note that lowering the RAM or restarting other computer #1 did not appear to help. Could this be an issue with the java being 64 bit? Will have to wait till tomorrow to change it. 

    Link to comment
    Share on other sites

    Neither 32 bit java nor jarfix helped, but thanks. However, I tried launching from cmd and was met with the following:

    [ERROR] Failed to connect to OSRS, retrying... (x10)

    Failed to start InstanceWrapper!

    log7j:ERROR No output stream or file set for the appender named [LocalFile].

    Link to comment
    Share on other sites

    Also note that <working machine> and <not-working machine> have exactly the same IP, firewall, etc and I'm not using a proxy.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.