Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Scripts not appearing in client


    Tinkerfitz
     Share

    Recommended Posts

    hello,

    I am trying to have scripts appear in my client, but none appear when I click the refresh buttons.

    I added a .jar to the scripts dreambot folder, but it doesn't seem to appear. Scripts I added from the SDN also don't show up in my account.

    Is the path possibly messed up? Would deleting and re-launching the client possibly fix this issue?

    Thank you : ~ )

    Link to comment
    Share on other sites

    I'd make sure you are signed in but if that doesn't work try deleting the DreamBot folder under your user profile and reruning dblauncher.jar.  

    Link to comment
    Share on other sites

    I've also heard that if someone in a local script is messed up, I don't know exactly what would cause it sorry, that it will prevent any scripts from showing up. Try removing the local script for a few minutes and seeing if the SDN scripts you have added start to show up.

    Link to comment
    Share on other sites

    Due to the removal of deprecated methods, it's possible there are outdated scripts added to your client. Try removing free scripts one by one until your scripts show back up (or remove your local scripts, try that first)

    Once you do find the one that caused the issues, I'd be grateful if you could post it back here so that we can take a look as to what caused the error.

    Link to comment
    Share on other sites

    On 9/16/2019 at 11:58 AM, Cystic said:

    I've also heard that if someone in a local script is messed up, I don't know exactly what would cause it sorry, that it will prevent any scripts from showing up. Try removing the local script for a few minutes and seeing if the SDN scripts you have added start to show up.

    Seems like this is what's causing the issue, the script was actually just a hello world made in Intellij that I wanted to use to test on the dreambot console. 

    Adding it into the scripts folder doesn't make any of the client scripts work, but removing it makes them all reappear.

    Maybe there is something wrong with the way I created the .jar?

    Link to comment
    Share on other sites

    2 hours ago, Tinkerfitz said:

    Seems like this is what's causing the issue, the script was actually just a hello world made in Intellij that I wanted to use to test on the dreambot console. 

    Adding it into the scripts folder doesn't make any of the client scripts work, but removing it makes them all reappear.

    Maybe there is something wrong with the way I created the .jar?

    I'm not sure, sorry. I don't know exactly what causes the issue, maybe Nezz can shine some light on it if you ask him. If nothing else I'd just delete the .jar 

    Link to comment
    Share on other sites

    1 hour ago, Cystic said:

    I'm not sure, sorry. I don't know exactly what causes the issue, maybe Nezz can shine some light on it if you ask him. If nothing else I'd just delete the .jar 

    Okay, I guess I will try writing another script and hopefully it won't get in the way of me using my own scripts ( ´・ω・)

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.