Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Unable to launch dreambot


    Recommended Posts

    Hey guys I'm having some trouble with dreambot and its getting pretty frustrating. I downloaded the latest version of java but when  I download dreambot launcher it wants to search in the app store for it. when I click launch dream bot it brings up my downloads window and ask me to save or launch, clicking launch just reopens my downloads window. I'm using Microsoft edge which doesn't support plug-ins such as java but have tried internet explorer with the same results. Any help would be greatly appreciated. Thank you

    Link to comment
    Share on other sites

    Sounds like you are on windows?

    try right clicking, open with..., java 8u211

    If that fails, try jarfix

    if that doesnt work... try powershell? rightclick DBLauncher.jar, copy, open powershell, type "java -jar" no qoutes, then right click, and enter. Copying the file and right clicking in powershell should paste the absolute path to db launcher, java -jar ensures its ran as a jar file in java.

    Edited by falloutr
    Link to comment
    Share on other sites

    Thanks for the reply and yes I'm on windows but still can't seem to figure it out. When I try opening with java or jarfix it opens a java tab for a split second then disappears. Maybe there's something wrong with my java installation because when using powershell it didn't recognize jar-fix. I don't want to take up too much of your time I appreciate the help. Should I consider having someone access my computer?

    Link to comment
    Share on other sites

    4 hours ago, juliobarbone said:

    Yes and I reinstalled it just to be sure everythings working right

    If you have java 8 and it's not working then try running jarfix. Can find on google.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.