Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Client tries logging in to wrong world?


    AsBakedAsCake
     Share

    Recommended Posts

    I've only recently just started having this problem with Dreambot. It's a bit script breaking so I figured I'd report it.

    It appears after you reach the 6 hour mark of time logged in, you're automatically logged out and it will bring up the world menu sometimes. This doesn't happen EVERY time, but when it does happen it breaks the script 90% of the time. (At least once or twice through a 24 hr period.)

    I just watched this happen as my script hit the 6 hour marker - world menu pops up, Dreambot randomly clicks a world from the list. Sometimes it works if it clicks the correct type of world (members/f2p), but a lot of the time it doesn't. Keep in mind my script is not using the world hopper at all.

    Since it randomly selects a world on this window it's sometimes trying to log into f2p while in member zone or vice versa. Also tries logging into high level total worlds. Clicking cancel then logging in works fine, maybe dreambot could do this?

    Edit: It appears after speaking with some people in chat that I'm not the only one with this problem. It's happening to others as well.

    Gif of issue (random world click): https://imgur.com/a/38bm4yo

    Debug:

    • [INFO]19:31:01: Starting random event solver LOGIN...
    • [INFO]19:31:01: Starting auto-login handler...
    • [ERROR]19:31:15: Failed to login with severity of 3, something is off with your RS membership! MEMBERS_AREA
    • [ERROR]19:31:15: Stopping script due to failed login attempts
    Edited by AsBakedAsCake
    Link to comment
    Share on other sites

    5 minutes ago, Nuclear Nezz said:

    When the world screen is open during login solver, it should click the cancel button.

    It's probably an issue with the is world screen open method, I'll take a look at it now.

     

    Thanks Nezz!

    Link to comment
    Share on other sites

    16 hours ago, Nuclear Nezz said:

    Done and released

    Appreciate the quick replies however after some testing I don't believe it's fixed yet Nezz.

    This is with client release 2.9.8.5:  https://imgur.com/a/G2m0CLA

    I will most certainly keep testing to help get this figured out though :)

    Upon doing more testing today, it appears the second the world menu is visible the mouse clicks randomly on the window. If it completely misses a world from the menu, it will then click cancel & continue.

    I had to make it miss myself, otherwise it seems to always click an area within the red bordered zone shown here: https://gyazo.com/48b9f0f6c992418b6c1bb11120604ea8

    Edited by AsBakedAsCake
    Link to comment
    Share on other sites

    23 hours ago, AsBakedAsCake said:

    Appreciate the quick replies however after some testing I don't believe it's fixed yet Nezz.

    This is with client release 2.9.8.5:  https://imgur.com/a/G2m0CLA

    I will most certainly keep testing to help get this figured out though :)

    Upon doing more testing today, it appears the second the world menu is visible the mouse clicks randomly on the window. If it completely misses a world from the menu, it will then click cancel & continue.

    I had to make it miss myself, otherwise it seems to always click an area within the red bordered zone shown here: https://gyazo.com/48b9f0f6c992418b6c1bb11120604ea8

    I had tested it myself, it closed the world screen. Are you using ac ustom login solver?

    Link to comment
    Share on other sites

    27 minutes ago, Nuclear Nezz said:

    I had tested it myself, it closed the world screen. Are you using ac ustom login solver?

    o.O I can test it again right now, I'm not using a custom solver at all.

    I'll let you know how it goes

    It's still not working, I'll PM you.

     

    Edited by AsBakedAsCake
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.