Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Frustrating bug


    Neb
     Share

    Recommended Posts

    Hey ever since thurseday update getclient.getworld method is fucked

     

    im not sure what causes it because it doesn't happen every time but it seems to be happening very frequently.

     

    https://imgur.com/a/fy5eF

     

    As you can see the account on the left looks like he is on world 384 but really he is logged into world 1.

     

    I thought this was a one off thing at first but it keeps happening now and it's fucking my muling up lol.

    Link to comment
    Share on other sites

    It's not broken.

    Something is defiantly fucked with it...

     

    I have f2p bots on multiple different pc's all doing the same thing and it diddn't start happening until after thursedays update.

     

    There is no reason getClient().getWorld() should return a world im not on lol.

    After talking to rick it seems to be quick hop related. Going to do some more testing today at this point im not really sure if its a dreambot bug or something serverside on runescape lol

    Edited by Neb
    Link to comment
    Share on other sites

    java.lang.NullPointerException

            at org.dreambot.api.methods.worldhopper.WorldHopper.qHopper(WorldHopper.java:311)

            at org.dreambot.api.methods.worldhopper.WorldHopper.quickHop(WorldHopper.java:297)

            at main.Main.onStart(Main.java:466)

            at org.dreambot.api.script.AbstractScript.run(AbstractScript.java:196)

            at java.lang.Thread.run(Unknown Source)

     

    I'm seeing this everytime I quickstart my botclient maybe it has something to do with it?

    Link to comment
    Share on other sites

    I'm now fairly positive this is related to using quickhop

    I wanna say I was told quickhop is either broken or buggy? I can't say with 100% confidence. But when I had issues similar to this i used hopWorld, and not quickHop

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.