Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Paint not displaying


    choucter
     Share

    Recommended Posts

    Just recently, the paint has stopped displaying on all of my scripts. I haven’t made any modifications to the scripts, and the only change I can see is that the client shows “SCRIPT RENDERING DISABLED” in the top heading. I haven't noticed this before and wondering if this is my issue. I’m running Dreambot 3.9.9.

    Unfortunately, t can’t figure out how to re-enable script rendering.

    ·       Ctrl-R toggles between script rendering disabled and all rendering disabled.

    ·       I don’t see anything in the client settings to enable rendering, only a checkbox to disable it.

    ·       Checking Javadocs, I found Client.setRenderingDisabled. I added Client.setRenderingDisabled(false); to one of my scripts but that didn’t change anything.

    ·       Lastly, I searched for something in the forum but everything I found explained how to disable rendering but not re-enable it.

    ·       I did find a suggestion to put a try…catch around the paint and check the error message. I’ve used try…catch successfully with a GUI but couldn’t get it to work with Paint.

    My question is could the script rendering being disabled cause my paints to stop working? If not, any suggestions what else it could be (different scripts, different characters, all fail to display the paint).

    Link to comment
    Share on other sites

    Hey there, you can re-enable the script paint by enabling Developer Mode in the settings (or CTRL+D I think), and it's in one of the menu bar items :)

    I'm not sure how it was disabled if you didn't do that manually though :o

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.