Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • NullPointerException with web walker


    logic0671
     Share

    Recommended Posts

    Recently got this exception out of the blue.

    I don't believe I had changed anything related to walking since the previous time when it worked fine, which leads me to believe it is on the client side.

    Basically my bot was walking to a bank in ardoune when it stopped moving for like 10 seconds and then the script shut off.

     

    Error:

    • [ERROR]17:41:10: Exception has occurred while running! Please report error to developer if problem persists:
    • java.lang.NullPointerException
    • at org.dreambot.api.wrappers.map.TileReference.getGridY(TileReference.java:110)
    • at org.dreambot.api.methods.walking.path.impl.LocalPath.walkTileMM(LocalPath.java:93)
    • at org.dreambot.api.methods.walking.path.impl.LocalPath.walk(LocalPath.java:77)
    • at org.dreambot.api.methods.walking.web.node.impl.bank.BankWebNode.execute(BankWebNode.java:42)
    • at org.dreambot.api.methods.walking.path.impl.GlobalPath.walk(GlobalPath.java:39)
    • at org.dreambot.api.methods.walking.impl.Walking.walk(Walking.java:125)
    • at MainClass.restock(MainClass.java:115) at MainClass.onLoop(MainClass.java:83)
    • at org.dreambot.api.script.AbstractScript.run(AbstractScript.java:264)
    • at java.lang.Thread.run(Unknown Source)

    Also, sometimes my script will randomly not walk at all. It will just stand there for minutes and minutes.

    Any help is appreciated!

    Edited by logic0671
    Link to comment
    Share on other sites

    Although ive not seen that error i have experienced web walker occasionally being unable to move for periods of time due to the "chunk/tile" its trying to click not being loaded in (usually on load boundries).

    Ideally catch the result of the walk() command as it returns if it was successful or not, if its not then you can either choose a closer point to walk too or tele out to a known location (home tp etc)

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.