Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • getting Nullpointer in all local scripts


    JayGatsby
     Share

    Recommended Posts

    Below is the Error I'm getting. Somehow all my local scripts do this as soon as the first getGameObjects().closest(XXX) is called. 
    Glad if someone can Help/Elaborate.

    In this specific case the Lined referred to (28) is 

    if (c.getGameObjects().closest("Rune Essence") != null) {XXX}
    
    Quote

    [ERROR]23:53:38: Exception has occurred while running! Please report error to developer if problem persists: java.lang.NullPointerException at org.dreambot.api.wrappers.graphics.ModelWrapper.getVerticesX(ModelWrapper.java:119) at org.dreambot.api.wrappers.interactive.model.EntityModel.(EntityModel.java:30) at org.dreambot.api.wrappers.interactive.GameObject.getModel(GameObject.java:309) at org.dreambot.api.wrappers.interactive.GameObject.exists(GameObject.java:358) at org.dreambot.api.methods.interactive.Interactables.lambda$all$0(Interactables.java:61) at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:174) at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1374) at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481) at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471) at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708) at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499) at org.dreambot.api.methods.interactive.Interactables.all(Interactables.java:61) at org.dreambot.api.methods.interactive.Interactables.closest(Interactables.java:103) at org.dreambot.api.methods.interactive.Interactables.closest(Interactables.java:81) at
    Nodes.Initialize.execute(Initialize.java:28) at main.Main.onLoop(Main.java:37) at org.dreambot.api.script.AbstractScript.run(AbstractScript.java:256) at java.lang.Thread.run(Thread.java:748)

     

    Link to comment
    Share on other sites

    8 hours ago, JayGatsby said:

    Just did that, still getting the same Error. I also discovered that it is the case with all scripts, not just my own.

    It was an error on our end from something Pandemic had changed, which I had him change back.

    Sorry for the late response, I've been traveling. Is the issue still happening for you?

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.