Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Can't seem to get new script to show in Local Scripts


    ThatGuyLo
     Share

    Recommended Posts

    I've written one script before and it worked as intended.

    I am currently working on another script and I want to start testing it now, but I cant seem to get it to show up in the local scripts in the launcher.

    I've checked:

    - JDK is 1.8

    - Artifacts are building to scripts file

    -Script Manifest is there, with no errors

    -No compiler errors in code

    -Deleted artifact built in scripts file and rebuilt to replace it in there

     

    I'm pretty new so I dont know what else to check

    Link to comment
    Share on other sites

    I should also add that the Local Scripts screen, upon clicking refresh, goes blank shortly after displaying "Loading..." which I believe implies that it is recognizing that there is a script in the folder, but that there must be some sort of error with it. 

    It is also the only script in the folder currently, although I added a free script to my account in order to check if everything was working properly.

    I noticed in my first script, when there was an issue, it not only made the local scripts box empty, but the free scripts showed as empty as well. 

    In my current case, though, my free script is still showing, so I assume it must be a different error. 

     

    My first error was being on the wrong JDK (11), and it worked out once I switched it to 1.8.

    Link to comment
    Share on other sites

    24 minutes ago, Hashtag said:

    Run the client with cmd and see if any errors are printed in the cmd console. Client's debug console doesn't show all errors.

    Ran with cmd and am getting no errors

    Link to comment
    Share on other sites

    *SOLVED*

     

    It seems I had 2 copies of DreamBot (and containing folders) in seperate locations, and I assume DBLauncher was reading from the file that I was not sending scripts to. Odd, though, that the local scripts screen stopped showing that there were no scripts to load rather and just became an empty box instead.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.