Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • requested implementation of missing methods in DepositBox


    Empyrean GB
     Share

    Recommended Posts

    Hello developers.

    Both the Bank and DepositBox have a multitude of deposit method. However they do not have the same methods. The one I'm mainly missing is the 'DepositAllExcept(Filter filter)' method in the Depositbox.

    Could we get this method implemented please? It can be useful for bots that use stand alone deposit boxes like the one in port saramin.

     

    The missing methods in Bank:

    -depositAll(Item item)

     

    The missing methods in DepositBox:

    -depositAllExcept(Filter filter)

    -depositAllExcept(String... names)

    -depositAllExcept(Integer... ids)

     

    One inconsistent name:

    Bank.depositAllEquipment() vs DepositBox.depositWornItems

     

    In the case that this change is found to be agreeable. can we mishaps slap an interface on the Bank/DepositBox objects for these methods so a reference of them can be used after opening for a generic method method?

     

    EmpyreanGB

    Link to comment
    Share on other sites

    I've added the missing methods, as well as deprecated the worn items and added in depositAllEquipment (nice catch)

    I agree that there should be a common class as their parent, I might not get that done on this next release, but I will add it on to my todo list.

     

    Thanks for the suggestions. :)

    Link to comment
    Share on other sites

    Glad that you are willing to look into it. I got an own implementation for now but I'll refactor it out later. I mean I think me having container classes basically mapping methods to an existing class is kinda ugly lol.

    Link to comment
    Share on other sites

    Guest
    This topic is now closed to further replies.
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.