Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Java Client Issue


    msdav
     Share

    Recommended Posts

    Hi, I am a new member and am trying to get the DBLaunch.jar to work with a proxy. When I click "Launch Client" with or without a proxy nothing happens except the screen goes away. I can get the bots to work only by going into the file and selecting client.jar, however with this option I can't get proxies and worry about a higher ban rate.

     

    I believe I have identified the issue with the help of Almonds who used TeamViewer to access my Macbook Pro. We uninstalled all versions of Java using multiple methods and downloaded the correct JDK 8 191. However, when I go to the terminal are run version -java is displays the following:

     

    java version "11.0.1" 2018-10-16 LTS

    Java(TM) SE Runtime Environment 18.9 (build 11.0.1+13-LTS)

    Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

     

    This makes no sense because there is no evidence of these versions of Java being on my Macbook and I cannot seem to get it to switch to the correct version. Any assistance would be most appreciated so I can safely use proxies.

     

    Thank you

    Screen Shot 2018-11-11 at 12.59.28 AM.png

    Screen Shot 2018-11-11 at 12.59.41 AM.png

    Screen Shot 2018-11-11 at 1.02.08 AM.png

    Link to comment
    Share on other sites

    Instead of doing java -jar etc
    You could use the direct path to the java 8 java.exe

    Otherwise, it seems you do have a java 11 installed on your system for whatever reason. Have you tried a restart as well (sounds hokey, but sometimes you need a restart to fix system variables)

    Link to comment
    Share on other sites

    Can you give me some instructions on how to use the direct path? I restarted my Macbook and still showing as using 11.0.1. Can't figure it out. Thank you

     

    Link to comment
    Share on other sites

    I'm unsure on mac, but if you find the directory where your java 8 folder is, then instead of doing java -jar you'd do

    /Your/Path/To/Java/java_8.101/java.exe -jar client.jar

    and then the rest like normal (don't forget the xboot, which you can find in the quickstart thread here

    or whatever it is on mac.

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.