Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Client won't load


    Slomedaris
     Share

    Recommended Posts

    Hi
     

    Downloaded the client recently but I got stuck at trying to launch it. Jar file opens fine but after I press "launch" in the menu it closes and nothing else happens. Check the link below (Gyazo GIF) to see what I mean. I think it crashes or something like that but I haven't been able to figure out what's causing it. So far I've tried to adjust the memory usage, deleting & re-downloading the launcher but none of that actually solved it or changed the behaviour.

    https://gyazo.com/9a856b5b3a309838e77539b1de7b4307
    Details :
    -  OS Mac OS Mojave 10.14
    - Java version : Java 8 Update 191 (Latest update as far as I know)
    - Jar file opens with Java

    Hope someone can help me with this,

    Thanks in advance 🙂

    Edited by Slomedaris
    Link to comment
    Share on other sites

    • 5 months later...
    1 hour ago, itsdaddyc said:

    probably not

    this is most likely an issue on your end, I replied to you in babble but will restate it here.  This is most likely an issue on your end with your systems configuration. 

     

    Please take sometime and go thru this long list of trouble shooting steps then let us know the results.  Just saying its broke wont open does not give anyone enough information to actually help you.

     

    1.) Do you have Java 8 installed? if not install it

    2.) When you click DBLauncher.jar does it launch the client or does it open as if it were to be extracted?  if so run JarFix like YohoJo said.

    3.) Do you have other version of Java installed? if so uninstall them so Java 8 is the only one installed.

    4.) Delete the Dreambot folder if there is one on your system (not sure where it is on Macs but do a bit of investigative work, and I am sure you can find it).

    5.) If you are running any sort of anti virus make sure it is not causing any problems with DBLauncher. 

    I am sure there are some more but those are just the common ones off the top of my head.  When I tested DreamBot on my MacBook Pro it had no issues so this is clearly isolated to your system related to how it is configured. 

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.