Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • IDE broke?


    Recommended Posts

    IDE doesnt seem to recgonize things anymore


    for example


    hgjgjhgj().get(item -> item.getName().endsWith("arrow")).interact("Wield"); 


    the mistype in this command isnt marked with a red line to show its wrong and the script executes things it shouldnt as if booleans are wrong?


    eg. if i do if(booleanname == true) and the boolean doesnt even exist it will execute it?


    tried removing and relocating the jar no luck, even creating a new project no luck.


    Any ideas?

    Edit: Narrows the cause down to this line


    getWorldHopper().hopWorld(getWorlds().getRandomWorld(world -> world != null && world.isMembers() == false && world.isDeadmanMode() == false && world.isPVP() == false
    && world.getMinimumLevel() == 0));
    have no idea why
    Link to comment
    Share on other sites


    This topic is now archived and is closed to further replies.

    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.