Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Could somebody help me setting up proxys?


    JoeBloggs
     Share

    Recommended Posts

    HI Friends, 

    Been a casual RS player for a number of years, recently decided I would check out botting as a change of scenery and I thoroughly enjoyed it. Its funny how the game is much more fun when you don't play it.

    Anyway i got my feet wet with the free client and some random free proxy i found, but now I have decided to do this properly. I purchased the upgraded client, and got myself 3 sweet and sexy private residential proxies from a site called Bestproxyandvpn. I am having a little trouble getting them to work. I set it up as the HTTP and after setting a username and password, tried it out on the web browser. This all works fine, so I guess the proxy itself is ok. As soon as i switch it to Socks5 the browser dies, which I believe is normal, then i enter the IP address into the thingy on the Dreambot launcher. The address/port/username/password are all correct, but the darn thing wont load RS. I have tried out all 3 that I have purchased with no luck, but they all work find with the web browser when on HTTP setting.

    Now as you probably can guess from my phrasings, I am a bit of a Noob, so no need to point that out to me, I know it already. I am assuming that I am overlooking some stupid little thing either on the proxy website or on the launcher.

    I would be very appreciative if some kind gentleman could assist me in making these darn things work. Preferably somebody familiar with this particular website, as I have an inkling that I'm missing something there

    Thanks a bunch chaps.

    Link to comment
    Share on other sites

    It may take a while to switch to the SOCKS5 mode, some places I have used have taken around 30 mins. What you could do is download a browser called "MX5", this will allow you to test web connection through the SOCKS5 proxy instead of HTTP.

    Make sure there are no hidden spaces in your IP/port/user/pass :)

    Link to comment
    Share on other sites

    Thanks for the reply. However now I am even more confused. I download the browser you mentioned, set up the proxy, voila it loads internet pages up fine, I double check on a whats my ip website, to make sure I am indeed using the proxy, and sure enough I am, all on Socks5.

    Excitedly I relaunch the Dreambot client, thinking it just needed time, as you suggested. To my dismay it is still not loading, I have checked the credentials about a dozen times, absolutely no mistakes.

    I also found what I believe to be a "proxy checker website", I punch in the IP and it says its not working, despite using the proxy to load the proxy checker site!

    This is the IP address, maybe you or somebody on here can tell me what is wrong with it. 

    45.59.28.17:13712

    And yes, when I enter the IP into the launcher, I do indeed separate the address and the port into their respective fields. (I learned that the hard way trying to get my previous free proxys to work :P)

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.