Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Building scripts using command line on linux.


    Qualphey
     Share

    Recommended Posts

    I'm using ArchLinux and I want to make a script. I don't want to use eclipse or any other IDE, because I like it the command line way.

    I've copied some example script and tried to build it by running these two commands:

    javac -classpath /home/qualphey/DreamBot/BotData/client.jar ./src/runeminer/*.java
    
    jar cvf main.jar ./src/runeminer/*.class

    The build process went through without any errors, but after copying `main.jar` to ~/DreamBot/Scripts I can't see it on the local scripts in dreambots script manager. Am I missing something?

    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.