Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Uploaded SDN script won't start, running locally works (Need Help)


    distraction
     Share

    Recommended Posts

    I uploaded my first script to the SDN the other day using this tutorial (https://dreambot.org/forums/index.php/topic/389-tutorial-how-to-upload-scripts-to-the-sdn-using-git/). I checked over the tutorial multiple times, and I can't find anything that I've done wrong. The only thing I noticed thats different is the tutorial guy used eclipse but I'm using Intellij. Once it was on the SDN, I added it and tried running it. When I click start, nothing happens. However, it does work if I run the local version. They are both using the same files (I haven't changed anything since pushing), and I don't think I missed any files when uploading because I just copied the whole src folder.

     

    The main problem is that I have no way to debug this. I cannot figure out why this is happening because no errors show up in the console. Does anyone have any idea of what I might have done wrong, or at least how I may be able to debug the issue? I'll include some images to show exactly how I pushed the files.

     

    This is the folder that I copied and uploaded (it contains two "packages" main and util that contain the .java files) - http://prntscr.com/fsdqh4
    Here is another image that shows all the files inside the src folder - http://prntscr.com/fse03b

    This is what it looks like inside smartgit - http://prntscr.com/fsdx7u

    Here are the two commits I made (the first one pushes all files, second one changes a single line of code, both were pushed before the new script request was accepted) -  http://prntscr.com/fse2vu

    (I did test again after the second commit and it still works locally)

     

    First commit (shows all .java files were pushed) - http://prntscr.com/fsdz2y

    Second commit (shows one file had changes) - http://prntscr.com/fsdzjw

     

    If there is anything else I can provide that would help figuring this out, please let me know!

    Edited by distraction
    Link to comment
    Share on other sites

    add logging, re-commit the files, then check console to see what it is doing, if nothing else it would refresh the sdn version when you ask for a recompile

    Good idea, thanks man. I'll try that.

     

     

    Update: Added logs and re-commited/pushed. Once the recompile request is accepted I'll post back with results.

    Dreamlicker ended up knowing what the issue was. It was that I used intellij builder to build the gui, and it creates an extra gui file (gui.form). The SDN only supports .java files, so that was the issue. I built a new GUI in eclipse and now its working on the SDN. The name is "AutoSmelter" if anyone wants to try it.

    Edited by distraction
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    ×
    ×
    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.