Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Can't run any scripts


    Recommended Posts

    I'm currently having problems running scripts of any kind it seems. I've tried a few scripts none are working, the ones that I have tried are XS chocolate Crusher, jdv Willows, and Ganja Woodcutter. I didn't want to buy one before I knew I could get them working. An example error would be when running the Ganja Woodcutter I get the following problem:


    • [ERROR]17:21:52: Exception has occurred while running! Please report error to developer if problem persists: java.lang.NullPointerException at org.dreambot.api.input.event.impl.mouse.impl.MoveEvent.getCanvasReportRate(MoveEvent.java:140) at org.dreambot.api.input.event.impl.mouse.impl.MoveEvent.pause(MoveEvent.java:435) at org.dreambot.api.input.event.impl.mouse.impl.MoveEvent.handleMovement(MoveEvent.java:394) at org.dreambot.api.input.event.impl.mouse.impl.MoveEvent.handleMovement(MoveEvent.java:284) at org.dreambot.api.input.event.impl.mouse.impl.MoveEvent.run(MoveEvent.java:92) at org.dreambot.api.input.event.impl.InteractionEvent.interact(InteractionEvent.java:131) at org.dreambot.api.input.event.impl.InteractionEvent.interact(InteractionEvent.java:98) at org.dreambot.api.wrappers.interactive.interact.Interactable.interact(Interactable.java:91) at org.dreambot.api.wrappers.interactive.interact.Interactable.interact(Interactable.java:63) at com.apoapsiselectronics.GanjaWoodcutter.GanjaWoodcutterMain.onLoop(Unknown Source) at org.dreambot.api.script.AbstractScript.run(AbstractScript.java:250) at java.lang.Thread.run(Unknown Source)   


    and the following error when running XS chocolate Crusher: 


    • [iNFO]17:26:20: ~~~ Caught exception: null  



    Also, my version of Java is said to be up to date with my computer running version 1.8.0_131


    Any help is appreciated!





    I should add that my Java is on my C: drive and my bot is on the D: drive Im not sure if that matters though

    Link to comment
    Share on other sites


    This topic is now archived and is closed to further replies.

    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.