Jump to content
Frequently Asked Questions
  • Are you not able to open the client? Try following our getting started guide
  • Still not working? Try downloading and running JarFix
  • Help! My bot doesn't do anything! Enable fresh start in client settings and restart the client
  • How to purchase with PayPal/OSRS/Crypto gold? You can purchase vouchers from other users
  • Try asking for help in the chatbox
  • Client not loading.


    Recommended Posts

    I click on the launcher, it brings up the little window that says the client is updated and ready to launch, but when I hit the launch button nothing happens. It was working fine until earlier today. I've tried restarting my pc, and re-downloading the client and neither worked. I am not using any proxy or VPN.

    Problem still persisting, starting to get pretty annoyed.

    Edited by Tranquil
    Link to comment
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Create New...

    Important Information

    We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.